92午夜利福社在线观看

当前位置: 网站92午夜利福社在线观看 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:筹码分散研究,古丰风云,XJP新极,操盘学实训版

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、筹码分散研究

{筹码分散研究}

B5:=COST(5);
DB5:=REF(B5,1);
B15:=COST(15);
DB15:=REF(B15,1);
B50:=((COST(51.91)+COST(48.09))/2+COST(50))/2;
DB50:=REF(B50,1);
B85:COST(85),COLOR00CCCC,POINTDOT;
DB85:=REF(B85,1),COLORFFCCAA,POINTDOT;
B95:COST(95),COLORFF5B90,POINTDOT;
DB95:=REF(B95,1),COLORFF5B90,POINTDOT;
STICKLINE(B5>=DB5,B5,DB5,6,0),COLORFAABEC,COLORGRAY;
 STICKLINE(B5<DB5,B5,DB5,6,1),COLOR00BB00,COLORGRAY;
 STICKLINE(B15>=DB15,B15,DB15,6,0),COLOR0099FF,COLORGRAY;
 STICKLINE(B15<DB15,B15,DB15,6,1),COLORBLUE,COLORGRAY;
 STICKLINE(B50>=DB50,B50,DB50,6,0),COLORRED,COLORGRAY;
 STICKLINE(B50<DB50,B50,DB50,6,1),COLORGRAY,COLORGREEN,COLORGRAY;
 STICKLINE(B85>=DB85,B85,DB85,6,0),COLOR00CCCC,COLORGRAY;
 STICKLINE(B85<DB85,B85,DB85,6,1),COLORFFCCAA,COLORGRAY;
 STICKLINE(B95>=DB95,B95,DB95,6,0),COLORMAGENTA,COLORGRAY;
 STICKLINE(B95<DB95,B95,DB95,6,1),COLORFF5B90,COLORGRAY;
压力线:DMA(COST(95),WINNER(COST(99.999))),COLOR00BB00;
拉升线:DMA(COST(75),WINNER(COST(99.999))),COLOR6600FF;
平均成本:DMA(COST(50),WINNER(COST(99.999))),COLORYELLOW;
三分线:DMA(COST(33),WINNER(COST(99.999))),COLORMAGENTA;
无利线:DMA(COST(1.5),WINNER(COST(99.999))),COLORGREEN;
STICKLINE(C>=O,C,O,3,0),COLORMAGENTA;
STICKLINE(C>=O,H,L,0,0),COLORMAGENTA;
STICKLINE(C<=O,C,O,3,0),COLORLIGREEN;
STICKLINE(C<=O,H,L,0,0),COLORLIGREEN;



2、古丰风云,波段指標

VAR3:=MA(CLOSE,13);
VAR4:=100-ABS(((CLOSE-VAR3)/(VAR3))*(100));
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/(100);
VAR8:=SMA((CLOSE-VAR5)/(VAR7),20,1);
VAR9:=SMA((OPEN-VAR5)/(VAR7),20,1);
VARA:=(3)*(VAR8)-(2)*(SMA(VAR8,15,1));
VARB:=(3)*(VAR9)-(2)*(SMA(VAR9,15,1));
VARC:=100-VARB;
VARD:=(REF(LOW,1))*(0.89999997);
VARE:=(LOW)*(0.89999997);
VARF:=((VARE)*(VOL)+(VARD)*(CAPITAL-VOL))/(CAPITAL);
VAR10:=EMA(VARF,30);
VAR11:=CLOSE-REF(CLOSE,1);
VAR12:=MAX(VAR11,0);
VAR13:=ABS(VAR11);
VAR14:=((SMA(VAR12,7,1))/(SMA(VAR13,7,1)))*(100);
VAR15:=((SMA(VAR12,13,1))/(SMA(VAR13,13,1)))*(100);
VAR16:=BARSCOUNT(CLOSE);
VAR17:=((SMA(MAX(VAR11,0),6,1))/(SMA(ABS(VAR11),6,1)))*(100);
VAR18:=(((-200))*(HHV(HIGH,60)-CLOSE))/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR19:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR1A:=SMA((SMA(VAR19,4,1)-50)*(2),3,1);
VAR1B:=((INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14)))*(100);
VAR1C:=SMA(VAR1B,4,1);
VAR1D:=SMA(VAR1C,3,1);
VAR1E:=((HHV(HIGH,30)-CLOSE)/(CLOSE))*(100);
VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
多线:SMA(VAR21,3,1),COLOR0000FF,LINETHICK2;
空线:SMA(多线,3,1),COLORLIBLUE,LINETHICK2;
介入:IF(CROSS(多线,空线) AND (多线<30),20,0),COLORYELLOW,LINETHICK2;
退出:IF(CROSS(空线,多线) AND (空线>75),85,100),COLOR008000,LINETHICK2;
{股民学院 ttuu8.com 整理}



3、XJP新极,回调到位抄底

{XJP新极}

VAR1:=1180303;
VAR2:=IF(1<=VAR1,1,0);
VAR3:=VOL<=REF(VOL,1)*0.73*VAR2 AND REF(VOL,2)*2*VAR2<=REF(VOL,1) AND REF(OPEN,1)*1.02*VAR2<REF(CLOSE,1);
VAR4:=BARSLAST(VAR3);
VAR5:=REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOSE,1)>REF(CLOSE,2)*1.097 OR (REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,2)>REF(CLOSE,3)*1.0597);
VAR6:=VOL<=REF(VOL,1)*0.73*VAR2 AND LLV(VOL,6)=VOL AND (OPEN+CLOSE)*0.5/MIN(OPEN,CLOSE)<1.017*VAR2 AND VAR5;
VAR7:=BARSLAST(VAR6);
VAR8:=(OPEN+CLOSE)*0.5/MIN(OPEN,CLOSE)<1.017 AND VAR7<4 AND VAR4<15 AND CAPITAL*100*CLOSE<65999998976 AND CLOSE<45;
VAR9:=REF(CLOSE,2)>REF(CLOSE,3)*1.09*VAR2 AND CLOSE<REF(CLOSE,2) AND REF(VOL,1)<REF(VOL,2)*1.4*VAR2;
VAR10:=REF(CLOSE,3)>REF(CLOSE,4)*1.09*VAR2 AND REF(CLOSE,1)<REF(CLOSE,3) AND REF(VOL,2)<REF(VOL,3)*1.4*VAR2;
VAR11:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR12:=LLV(LOW,36);
VAR13:=HHV(HIGH,30);
VAR14:=EMA((CLOSE-VAR12)/(VAR13-VAR12)*4,4)*25;
VAR15:=VAR11>=VAR14 AND (VAR9 OR VAR10) AND VOL<=REF(VOL,1)*0.73 AND CAPITAL*100*CLOSE<65999998976 AND CLOSE<45 AND CLOSE>5;
XG:VAR8 OR VAR15;
{股民学院 ttuu8.com 整理}



4、操盘学实训版

攻击线:EMA(CLOSE,5),COLORWHITE,LINETHICK2;
操盘线:EMA(CLOSE,10),COLORCYAN,LINETHICK2;
辅助线:EMA(CLOSE,20),COLORMAGENTA,LINETHICK2;
生命线:EMA(CLOSE,30),COLORGREEN,LINETHICK2;
决策线:EMA(CLOSE,60),COLORYELLOW,LINETHICK2;
趋势线:EMA(CLOSE,120),COLORBLUE,LINETHICK2;
全年线:EMA(CLOSE,240),COLORRED,LINETHICK3;
 
高1:=REF(HHV(H,DATE),0);
低1:=REF(LLV(L,DATE),0);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
 
顶:REFDATE(高1,DATE),COLORRED,DOTLINE;
一0.809:REFDATE(H1,DATE),COLORYELLOW,DOTLINE;
二0.618:REFDATE(H2,DATE),COLORMAGENTA,DOTLINE;
三0.500:REFDATE(H3,DATE),COLORWHITE,DOTLINE;
四0.382:REFDATE(H4,DATE),COLORGREEN,DOTLINE;
五0.191:REFDATE(H5,DATE),COLORYELLOW,DOTLINE;
底:REFDATE(低1,DATE),COLORGREEN,DOTLINE;
 
IF(攻击线>=REF(攻击线,1),攻击线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(攻击线<=REF(攻击线,1),攻击线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(操盘线>=REF(操盘线,1),操盘线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(操盘线<=REF(操盘线,1),操盘线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(辅助线>=REF(辅助线,1),辅助线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(辅助线<=REF(辅助线,1),辅助线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(生命线>=REF(生命线,1),生命线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(生命线<=REF(生命线,1),生命线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(决策线>=REF(决策线,1),决策线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(决策线<=REF(决策线,1),决策线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(趋势线>=REF(趋势线,1),趋势线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(趋势线<=REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK4;
IF(全年线>=REF(全年线,1),全年线,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(全年线<=REF(全年线,1),全年线,DRAWNULL),COLORGREEN,LINETHICK4;
{画K线} 
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(CURRBARSCOUNT=1,顶,'历史高点'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,一0.809,'0.809'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,二0.618,'0.618'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,三0.500,'0.500'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,四0.382,'0.382'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,五0.191,'0.191'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,底,'历史低点'),COLORWHITE;

上一篇:通达信源码精选:蜡烛图全景图,操盘铁律,筹码红绿柱,筹码分布

下一篇:通达信公式下载:经传旗舰版全套指标(没导入密码)79个