92午夜利福社在线观看

当前位置: 网站92午夜利福社在线观看 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:缩量买入,缩量过高量顶,直线型移花宫

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、缩量买入

{缩量买入}
M1:=5;
M2:=20;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);
VAR2:=1*AMOUNT;
MA1:=1*MA(AMOUNT,5);
MA2:=1*MA(AMOUNT,10);
三十日天量:=HHV(VAR2,30)=VAR2;
六十日天量:=HHV(VAR2,60)=VAR2;
百日天量:=HHV(VAR2,100)=VAR2;
一年天量:=HHV(VAR2,250)=VAR2; 
STICKLINE(三十日天量,VOLUME,VOLUME*0.7,1,0),COLORMAGENTA;
STICKLINE(六十日天量,VOLUME,VOLUME*0.7,1,0),COLORYELLOW; 
STICKLINE(百日天量,VOLUME,VOLUME*0.7,1,0),COLORGREEN;
STICKLINE(一年天量,VOLUME,VOLUME*0.7,1,0),COLORFF7100;
三十日地量:=LLV(VAR2,30)=VAR2;
六十日地量:=LLV(VAR2,60)=VAR2;
百日地量:=LLV(VAR2,100)=VAR2;
一年地量:=LLV(VAR2,250)=VAR2;
STICKLINE(三十日地量,-50000,0,1,0),COLORMAGENTA;
STICKLINE(六十日地量,-50000,0,1,0),COLORYELLOW;
STICKLINE(百日地量,-50000,0,1,0),COLORGREEN;
STICKLINE(一年地量,-50000,0,1,0),COLORFF7100;
IF(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),VOLUME*5,0),COLORYELLOW,LINETHICK2;
{股民学院 ttuu8.com 整理}




2、缩量过高量顶

缩量过高量顶

 TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:=IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL);HH:=HHV(VOL,10);
T:=BARSLAST(HH=VOL);
缩量过高量顶:CROSS(C,REF(H,T))  AND VVOL<=HHV(V,T)*0.7  AND V<=REF(V,1)
AND  NOT(DYNAINFO(4)=0);

 
一般情况下:缩量过高量顶公式源码----转强个股选股策略
高量的顶优先取高量的最高价,是股价的安全线,高量底部最低价是股价的风险线,股价在高量底部下运行,风险是很大的,而在高量顶部之上运行是安全的,高量是我们抄底逃顶的尺度。 我们伏击的位置在股价突破高量顶部之时。
请量友不要过份相信公式的威力,选股公式只是提供一种思路,提供一个具备相同形态个股的范围,应结合市场环境,趋势,位置去进一步筛选,选股只是快速找出同形态个股的方法而已。



3、直线型移花宫

最高点:REFDATE(CONST(REF(HHV(H,0),0)),DATE),LINETHICK1,COLORMAGENTA;
最低点:REFDATE(CONST(REF(LLV(L,0),0)),DATE),LINETHICK1,COLORGREEN;
 
分界线:CONST(COST(50)),COLORYELLOW,LINETHICK3;
建仓线:CONST(COST(20)),COLORBLUE,LINETHICK3;
基准线:CONST(DMA(AMOUNT/(100*VOL),VOL/CAPITAL)),COLORMAGENTA,LINETHICK2; 
 
 
GD:=CONST(FINDHIGH(H,0,最高点*10,1));
GT:=CONST(BARSLAST(GD=H))+1;
DD:=CONST(FINDLOW(L,0,最低点*10,1));
DT:=CONST(BARSLAST(DD=L))+1;
 
上行1号线:基准线*1.10,DOTLINE;
上行2号线:上行1号线*1.10,DOTLINE;
上行3号线:上行2号线*1.10,DOTLINE;
上行4号线:上行3号线*1.10,DOTLINE;
上行5号线:上行4号线*1.10,DOTLINE;
上行6号线:上行5号线*1.10,DOTLINE;
上行7号线:上行6号线*1.10,DOTLINE;
上行8号线:上行7号线*1.10,DOTLINE;
上行9号线:上行8号线*1.10,DOTLINE;
 
下行1号线:基准线*0.90,DOTLINE;
下行2号线:下行1号线*0.90,DOTLINE;
下行3号线:下行2号线*0.90,DOTLINE;
下行4号线:下行3号线*0.90,DOTLINE;
下行5号线:下行4号线*0.90,DOTLINE;
下行6号线:下行5号线*0.90,DOTLINE;
下行7号线:下行6号线*0.90,DOTLINE;
下行8号线:下行7号线*0.90,DOTLINE;
下行9号线:下行8号线*0.90,DOTLINE;
 
 
{画K线} 
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
 
 
{拉升起点:=REFDATE(CONST(REF(LLV(L,0),0)),DATE)*1.0,DOTLINE;}
{拉升起点:=REFDATE(CONST(COST(0.001)),DATE)*1.00,DOTLINE;}
 
拉升10%:=基准线*1.1,DOTLINE;
拉升20%:=拉升10%*1.1,DOTLINE;
拉升30%:=拉升20%*1.1,DOTLINE;
拉升40%:=拉升30%*1.1,DOTLINE;
拉升50%:=拉升40%*1.1,DOTLINE;
拉升60%:=拉升50%*1.1,DOTLINE;
拉升70%:=拉升60%*1.1,DOTLINE;
拉升80%:=拉升70%*1.1,DOTLINE;
拉升90%:=拉升80%*1.1,DOTLINE;
拉升100%:=拉升90%*1.1,DOTLINE;
拉升110%:=拉升100%*1.1,DOTLINE;
拉升120%:=拉升110%*1.1,DOTLINE;
拉升130%:=拉升120%*1.1,DOTLINE;
拉升140%:=拉升130%*1.1,DOTLINE;
拉升150%:=拉升140%*1.1,DOTLINE;
拉升160%:=拉升150%*1.1,DOTLINE;
拉升170%:=拉升160%*1.1,DOTLINE;
拉升180%:=拉升170%*1.1,DOTLINE;
拉升190%:=拉升180%*1.1,DOTLINE;
拉升200%:=拉升190%*1.1,DOTLINE;
 
 
拉升210%:=拉升200%*1.1,DOTLINE;
拉升220%:=拉升210%*1.1,DOTLINE;
拉升230%:=拉升220%*1.1,DOTLINE;
拉升240%:=拉升230%*1.1,DOTLINE;
拉升250%:=拉升240%*1.1,DOTLINE;
拉升260%:=拉升250%*1.1,DOTLINE;
拉升270%:=拉升260%*1.1,DOTLINE;
拉升280%:=拉升270%*1.1,DOTLINE;
拉升290%:=拉升280%*1.1,DOTLINE;
拉升300%:=拉升290%*1.1,DOTLINE;
 
 
DRAWTEXT(CURRBARSCOUNT=DT,基准线,'拉升起点'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升10%,'拉升10%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升20%,'拉升20%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升30%,'拉升30%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升40%,'拉升40%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升50%,'拉升50%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升60%,'拉升60%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升70%,'拉升70%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升80%,'拉升80%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升90%,'拉升90%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升100%,'拉升100%'),COLORWHITE;
 
DRAWTEXT(CURRBARSCOUNT=DT,拉升110%,'拉升110%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升120%,'拉升120%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升130%,'拉升130%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升140%,'拉升140%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升150%,'拉升150%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升160%,'拉升160%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升170%,'拉升170%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升180%,'拉升180%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升190%,'拉升190%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升200%,'拉升200%'),COLORWHITE;
 
DRAWTEXT(CURRBARSCOUNT=DT,拉升210%,'拉升210%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升220%,'拉升220%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升230%,'拉升230%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升240%,'拉升240%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升250%,'拉升250%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升260%,'拉升260%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升270%,'拉升270%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升280%,'拉升280%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升290%,'拉升290%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升300%,'拉升300%'),COLORWHITE;
 
{回踩起点:=REFDATE(CONST(REF(HHV(H,0),0)),DATE)*1.0,DOTLINE;}
{回踩起点:=REFDATE(CONST(COST(99.999)),DATE)*1.0,DOTLINE;}
 
回踩10%:=基准线*0.90,DOTLINE;
回踩20%:=回踩10%*0.90,DOTLINE;
回踩30%:=回踩20%*0.90,DOTLINE;
回踩40%:=回踩30%*0.90,DOTLINE;
回踩50%:=回踩40%*0.90,DOTLINE;
回踩60%:=回踩50%*0.90,DOTLINE;
回踩70%:=回踩60%*0.90,DOTLINE;
回踩80%:=回踩70%*0.90,DOTLINE;
回踩90%:=回踩80%*0.90,DOTLINE;
回踩100%:=回踩90%*0.90,DOTLINE;
 
回踩110%:=回踩100%*0.90,DOTLINE;
回踩120%:=回踩110%*0.90,DOTLINE;
回踩130%:=回踩120%*0.90,DOTLINE;
回踩140%:=回踩130%*0.90,DOTLINE;
回踩150%:=回踩140%*0.90,DOTLINE;
回踩160%:=回踩150%*0.90,DOTLINE;
回踩170%:=回踩160%*0.90,DOTLINE;
回踩180%:=回踩170%*0.90,DOTLINE;
回踩190%:=回踩180%*0.90,DOTLINE;
回踩200%:=回踩190%*0.90,DOTLINE;
 
 
回踩210%:=回踩200%*0.90,DOTLINE;
回踩220%:=回踩210%*0.90,DOTLINE;
回踩230%:=回踩220%*0.90,DOTLINE;
回踩240%:=回踩230%*0.90,DOTLINE;
回踩250%:=回踩240%*0.90,DOTLINE;
回踩260%:=回踩250%*0.90,DOTLINE;
 
 
 
DRAWTEXT(CURRBARSCOUNT=GT,基准线,'回踩起点'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩10%,'回踩10%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩20%,'回踩20%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩30%,'回踩30%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩40%,'回踩40%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩50%,'回踩50%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩60%,'回踩60%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩70%,'回踩70%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩80%,'回踩80%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩90%,'回踩90%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩100%,'回踩100%'),COLORYELLOW;
 
DRAWTEXT(CURRBARSCOUNT=GT,回踩110%,'回踩110%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩120%,'回踩120%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩130%,'回踩130%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩140%,'回踩140%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩150%,'回踩150%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩160%,'回踩160%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩170%,'回踩170%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩180%,'回踩180%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩190%,'回踩190%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩200%,'回踩200%'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=GT,回踩210%,'回踩210%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩220%,'回踩220%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩230%,'回踩230%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩240%,'回踩240%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩250%,'回踩250%'),COLORYELLOW;

上一篇:通达信源码精选:萧啸擒龙捉妖X,冰魄牛回头,筹码均线主图

下一篇:通达信精选下载组合公式15个